Opened 5 years ago

Closed 5 years ago

#14992 closed (duplicate)

Template recursion

Reported by: IsakovAN Owned by: nobody
Component: Template system Version: master
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

I'm trying to implement recursion of the template:

test.html:
{% if some.condition %}
Some stuff
{% include test.html with x=... %}

{% endif %}

Almost all works fine but...
"maximum recursion depth exceeded while calling a Python object"

It seems that "include" have been parsed irrespective of "if" condition. I think this shoud be fixed in because of:

  1. Performance
  2. Recursion

Change History (1)

comment:1 Changed 5 years ago by lrekucki

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #3544.

Note: See TracTickets for help on using tickets.
Back to Top