Code

Opened 8 years ago

Closed 8 years ago

#1498 closed defect (duplicate)

No escaping for DateFormat in 'date' filter

Reported by: waylan@… Owned by: adrian
Component: Template system Version: master
Severity: normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Escaped characters in the DateFormat only work with the 'now' template tag, but not the 'date' filter. Some examples:

{% now "jS o\f F" %}

will return 13th of March as it should. But when doing this:

{{ post.pub_date|date:"jS o\f F" }}

we get 13th o9:54 March instead.

See this thread for discussion: http://groups.google.com/group/django-users/browse_thread/thread/608da74525d82372/05968d618dbdecfa#05968d618dbdecfa

Attachments (0)

Change History (1)

comment:1 Changed 8 years ago by dcf@…

  • Resolution set to duplicate
  • Status changed from new to closed

A duplicate of #1198.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.