Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#14906 closed (fixed)

r14915 removed alternative month names from Polish translation added in r14000

Reported by: jbl1 Owned by: zgoda
Component: Translations Version: master
Severity: Keywords:
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Given the template code:

<p>Dzisiejsza data: {{ dzisiaj|date:"j F Y" }}</p>
<p>Dzisiejsza data: {{ dzisiaj|date:"j E Y" }}</p>

I get the following:

Dzisiejsza data: 15 Grudzień 2010

Dzisiejsza data: 15 December 2010

Expected is (the second line was in error):

Dzisiejsza data: 15 Grudzień 2010

Dzisiejsza data: 15 grudnia 2010

as per http://docs.djangoproject.com/en/dev/ref/templates/builtins/, which says:

E 	Month, locale specific alternative representation usually used for long date representation. 	'listopada' (for Polish locale, as opposed to 'Listopad')

Of course USE_I18N and USE_L10N are set to True which can be seen form the first lines of the sample renderings. My Django version is "bleeding edge" SVN-14918.

Is that a bug or am I overseeing something.

Change History (6)

comment:1 Changed 5 years ago by ramiro

  • Component changed from Template system to Translations
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

This seems to be caused by a outdated Polish translation, please get in touch with the team maintaing it (and even better, offer help :-)): see wiki:Localization and the header of the django/conf/locale/pl/LC_MESSAGES/django.po file for contact details.

comment:2 Changed 5 years ago by jezdez

  • milestone set to 1.3

This is because r14915 removed the updates added in r14900, sigh.

comment:3 Changed 5 years ago by jezdez

  • Summary changed from Date month format character "E" not working for Polish to r14915 removed alternative month names from Polish translation added in r14000

comment:4 Changed 5 years ago by zgoda

  • Owner changed from nobody to zgoda
  • Status changed from new to assigned

I used wrong django version to run makemessages and all context-based translations was lost in this changeset.

comment:5 Changed 5 years ago by zgoda

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [14919]) Fixed #14906: lost context-based translations for Polish

comment:6 Changed 4 years ago by jacob

  • milestone 1.3 deleted

Milestone 1.3 deleted

Note: See TracTickets for help on using tickets.
Back to Top