Opened 5 years ago

Closed 5 years ago

Last modified 2 years ago

#14857 closed Uncategorized (duplicate)

has_results cleanup

Reported by: wkornewald Owned by: nobody
Component: Uncategorized Version: master
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no


The attached patch moves the SQL-specific code (just three lines) from sql.Query to SQLCompiler. This allows to override the has_results() behavior in the backend which is needed for NoSQL support. It would be nice if you could commit the patch. Thanks!

Attachments (1)

has_results.diff (1.4 KB) - added by wkornewald 5 years ago.
patch against trunk

Download all attachments as: .zip

Change History (5)

Changed 5 years ago by wkornewald

patch against trunk

comment:1 Changed 5 years ago by russellm

  • milestone 1.3 deleted
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

Duplicate of #13774

comment:2 Changed 5 years ago by russellm

  • Resolution set to wontfix
  • Status changed from new to closed
  • Summary changed from [patch] has_results cleanup to has_results cleanup

Sorry - not a duplicate -- pasted a comment into the wrong tab.

However, I'm going to mark this wontfix. NoSQL support isn't something that needs to be addressed piecemeal. This isn't the only place that raw SQL leaks out of the compiler; these leaks need to be addressed as a whole, not piecemeal. As I've told you *many* times Waldemar, NoSQL support is on my radar for 1.4, when we address merging Alex's query-refactor SoC branch.

comment:3 Changed 5 years ago by wkornewald

Note that query-refactor doesn't contain anything that doesn't already exist in Django-nonrel, so I'd appreciate if you could at least take a look at Django-nonrel before you merge query-refactor (which BTW needs some more work). Anyway, I've started documenting all existing and missing changes in NoSqlSupport.

comment:4 Changed 2 years ago by timo

  • Easy pickings unset
  • Resolution changed from wontfix to duplicate
  • Severity set to Normal
  • Type set to Uncategorized
  • UI/UX unset

Duplicate of #17339 which has been merged.

Note: See TracTickets for help on using tickets.
Back to Top