Code

Opened 3 years ago

Closed 3 years ago

#14838 closed (duplicate)

django admin: a staff memeber can delete itself

Reported by: anonymous Owned by: nobody
Component: Contrib apps Version: 1.2
Severity: Keywords:
Cc: lists@… Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

If you give to a staff member the "can delete user" permission, then it can delete itself. Delete user operation should be disabled for the actually logged in user

Attachments (0)

Change History (3)

comment:1 Changed 3 years ago by anonymous

  • Cc nicola.murino@… added
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

comment:2 Changed 3 years ago by anonymous

  • Cc lists@… added; nicola.murino@… removed

comment:3 Changed 3 years ago by kmtracey

  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #8159.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.