Code

Opened 3 years ago

Closed 3 years ago

#14719 closed (duplicate)

Different attributes for DateInput and TimeInput in SplitDateTimeWidget

Reported by: slink <gabor@…> Owned by: nobody
Component: Forms Version: master
Severity: Keywords: widget date time
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Current implementation of SplitDateTimeWidget accepts an attrs dictionary and passes it to both DateInput and TimeInput widgets. It would be nice if widgets may have different attributes while attrs still applies to both.

For instance:

widget = SplitDateTimeWidget(attrs={'class': 'input-field'},
                             date_attrs={'dojoType': 'dijit.form.DateTextBox'},
                             time_attrs={'dojoType': 'dijit.form.DateTextBox'})

Attachments (0)

Change History (1)

comment:1 Changed 3 years ago by russellm

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #14718

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.