Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#14708 closed (fixed)

Document available mapping keys for form field error messages.

Reported by: adamv Owned by: nobody
Component: Documentation Version: master
Severity: Keywords:
Cc: Triage Stage: Accepted
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

The error messages for some form fields have mapping keys that will be replaced into the provided error strings. The attached patch documents these keys.

Attachments (2)

form-field-errors.diff (2.6 KB) - added by adamv 5 years ago.
document-mapping-keys.diff (3.0 KB) - added by adamv 5 years ago.
Rebased against trunk.

Download all attachments as: .zip

Change History (8)

Changed 5 years ago by adamv

comment:1 Changed 5 years ago by adamv

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

Also: Recommend resolving #8104 as a duplicate of this issue.

comment:2 Changed 5 years ago by gabrielhurley

  • milestone set to 1.3
  • Triage Stage changed from Unreviewed to Accepted

Agreed with your recommendation, adam. I'll give the patch further review later on before I commit it, but so far it looks good.

comment:3 Changed 5 years ago by anonymous

gabriel, not related per se, but another documentation addition in the same file: http://code.djangoproject.com/ticket/11496
Potentially that patch could also be pulled in regardless of whether or not it satisfies bug 11496.

Changed 5 years ago by adamv

Rebased against trunk.

comment:4 Changed 5 years ago by timo

  • Resolution set to fixed
  • Status changed from new to closed

(In [15080]) Fixed #14708 - Document available keys for form field error messages; thanks adamv.

comment:5 Changed 5 years ago by timo

(In [15081]) [1.2.X] Fixed #14708 - Document available keys for form field error messages; thanks adamv.

Backport of r15080 from trunk.

comment:6 Changed 4 years ago by jacob

  • milestone 1.3 deleted

Milestone 1.3 deleted

Note: See TracTickets for help on using tickets.
Back to Top