Code

Opened 3 years ago

Closed 3 years ago

#14690 closed (duplicate)

{% block %} defined in {% included %} page isn't 'repleacable'

Reported by: pma_ Owned by: nobody
Component: Template system Version: 1.2
Severity: Keywords: block include
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

I moved part of template to external file that is included in base template. My block definition in derived template doesn't replace content in include. There are no restriction in docs so I believe it's a bug.

a.html
{% include b.html %}

b.html
{% block x}replaced?{% endblock %}

c.html
{% extends a.html %}

{% block x}new value{% endblock %}

Attachments (0)

Change History (1)

comment:1 Changed 3 years ago by lrekucki

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Looks like a duplicate of #12008.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.