Opened 4 years ago

Closed 4 years ago

#14683 closed (duplicate)

FormWizard done() method doesn't get the last form in form_list

Reported by: Luke Sneeringer <lukesneeringer@…> Owned by: nobody
Component: contrib.formtools Version: 1.3-alpha
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Good evening,
In Django 1.3 alpha, there's an issue where the last form is not included in the form_list list that is sent to the done() method of a FormWizard.

When trying to access the form from the list, I get an IndexError (list index out of range). self.form_list does include the form, but those are unbound forms. The bound form with the POST data no longer makes it to the done method.

I verified that this problem also exists in the SVN trunk. It works in 1.2.3.

Change History (1)

comment:1 Changed 4 years ago by lukeplant

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #14576

Note: See TracTickets for help on using tickets.
Back to Top