Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#14620 closed (duplicate)

django.utils.translation.get_language doesn't use settings

Reported by: feuervogel Owned by: nobody
Component: Core (Other) Version: 1.2
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:


I'm using the test_suite option in my setup. When specifying a LANGUAGE_CODE l10n in form-fields doesn't work properly. I've figured out that django.utils.translation.get_language isn't working as expected. Please check out my test app to find out.

I'm sorry but I can't provide a patch.

When using this app withing a djangoproject with a LANGUAGE_CODE set, everything's working fine.

Change History (3)

comment:1 Changed 5 years ago by feuervogel

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

sorry, it should've read 'in my setup' not 'in my setup'.

comment:2 Changed 5 years ago by jezdez

  • Resolution set to duplicate
  • Status changed from new to closed

I believe this is a duplicate of #9340

comment:3 Changed 5 years ago by feuervogel

ok, seems to be a related bug at least. to make it clear again:

python test

fails, but installing language_bug into a project and then

python test


Note: See TracTickets for help on using tickets.
Back to Top