Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#14581 closed (duplicate)

__isnull=False not working for one to one relationships

Reported by: sircco Owned by: Daishiman
Component: Database layer (models, ORM) Version: master
Severity: Keywords: pscyopg2
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description (last modified by Alex)

I am using psycopg2 backend

A.fillter(B__isnull=False)[0].B throws DoesNotExist exception

Change History (5)

comment:1 Changed 4 years ago by Alex

  • Description modified (diff)
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

Corrected formatting.

comment:2 Changed 4 years ago by gsakkis

Please post a fully reproducible example. If you can't spend a few minutes to do it right and instead post a one liner with a typo in it (fillter instead of filter) and undefined "A" and "B", why would anyone spend much more time to reproduce it and come up with a fix for it ?

comment:3 Changed 4 years ago by Daishiman

  • Owner changed from nobody to Daishiman

comment:4 Changed 4 years ago by Daishiman

  • milestone set to 1.3
  • Resolution set to duplicate
  • Status changed from new to closed

This ticket is a duplicate of #13815.

comment:5 Changed 4 years ago by jacob

  • milestone 1.3 deleted

Milestone 1.3 deleted

Note: See TracTickets for help on using tickets.
Back to Top