Opened 5 years ago

Closed 5 years ago

#14520 closed (fixed)

Regression in test speed, and memory usage

Reported by: Alex Owned by: nobody
Component: Testing framework Version: master
Severity: Keywords:
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:


Since the transaction-contextmanager commit the test suite seems to have a slow-growing memory leak (beginning 1/2 - 3/4 of the way through) and a significant performance regression. This is visible using SQLite backend (in memory).

Change History (2)

comment:1 Changed 5 years ago by Alex

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

comment:2 Changed 5 years ago by Alex

  • Resolution set to fixed
  • Status changed from new to closed

(In [14312]) Fixed #14520 -- fixed a memory leak when running the test suite.

Note: See TracTickets for help on using tickets.
Back to Top