Opened 5 years ago

Closed 5 years ago

#14509 closed (duplicate)

Changeset 14293 broke static media serving when settings.DEBUG = True

Reported by: djm Owned by: nobody
Component: Contrib apps Version: master
Severity: Keywords: static, debug, serve
Cc: mail@… Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Changeset 14293 brought in a new ImproperlyConfigured Exception to stop the use of the static serving method when running with DEBUG mode off.

However the logic is incorrect; Line 44 should read if *not* settings.DEBUG: as this would check for when DEBUG is False and apply the exception.

Only a small one, will submit a patch in a sec.

cheers,

Darian

Change History (1)

comment:1 Changed 5 years ago by lukeplant

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #14507

Note: See TracTickets for help on using tickets.
Back to Top