Code

Opened 4 years ago

Closed 4 years ago

Last modified 3 years ago

#14487 closed (fixed)

Stop leaking unittest2 as 'unittest' from django.test.simple

Reported by: jezdez Owned by: nobody
Component: Testing framework Version: 1.2
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

This is especially dangerous for cases of from django.test.simple import * where a import unittest comes before.

Attachments (0)

Change History (3)

comment:1 Changed 4 years ago by russellm

  • Resolution set to fixed
  • Status changed from new to closed

(In [14258]) Fixed #14487 -- Prevented unittest from leaking into scope via a 'from django.test.testcases import *' import. Thanks to Jannis for the report.

comment:2 Changed 4 years ago by russellm

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

Although this bug technically exists in 1.2 as well, I'm not going to backport, The issue isn't as critical with 1.2 because there isn't a second unittest causing problems; plus, this could break code in production. That code probably *should* break, since it's relying on imports that it shouldn't, but it's a breakage that we don't need to enforce.

comment:3 Changed 3 years ago by jacob

  • milestone 1.3 deleted

Milestone 1.3 deleted

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.