Code

Opened 4 years ago

Closed 4 years ago

#14367 closed (duplicate)

Please add as_p() to form fields

Reported by: dfoerster Owned by: nobody
Component: Forms Version: 1.2
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

The form.as_p() method is very handy but can't always be user. When customizing the layout of a form one has to specify for each field the label (using get_label), a possible error message and the form widget.

It would be very handy, if form fields had a as_p() method that prints the fields label, error message and widget just as the forms as_p() method does.

Attachments (0)

Change History (1)

comment:1 Changed 4 years ago by dpn

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Hey, I'm gonna mark this as a dupe of #3111 . as_p isn't mentioned there, but its the same idea :)

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.