Opened 6 years ago

Closed 6 years ago

Last modified 5 years ago

#14355 closed (fixed)

"readonly" fields don't display their "help_text" in admin

Reported by: jester Owned by: wamberg
Component: contrib.admin Version: 1.2
Severity: Keywords: readonly help_text
Cc: Triage Stage: Ready for checkin
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Steps to reproduce

  1. Define a Model, whose field(s) specify help_text, e.g.:
class MyModel(Model):
    my_regular_field = CharField(max_length=255, help_text="this is my regular field")
    my_readonly_field = CharField(max_length=255, help_text="this is my readonly field")
  1. Define a ModelAdmin for your Model, including one of its fields in readonly_fields, e.g.:
class MyModelAdmin(ModelAdmin):
    fields = 'my_regular_field', 'my_readonly_field'
    readonly_fields = 'my_readonly_field',
admin.site.register(MyModel, MyModelAdmin)

In the object view/edit screen, "My regular field" will have help text, "My readonly field" will not.

Expectation

The expected behavior is that readonly fields will work just like "regular" fields, except their widget will be their plain value rather than a form element -- i.e., any string specified as "help_text" should be displayed after the field.

Uneducated guesswork

I don't dig very deep into the workings of the admin very often, and so, obviously, what I'm about to say may be entirely unhelpful. However, it appears that helpers.AdminReadonlyField constructs a limited, faux field object, a dict, at self.field, rather than assign the appropriate BoundField instance. This is perhaps because readonly fields are not available to it in self.form.fields. In the template, field.field.field.help_text fails, as the dict does not contain "help_text", (and I'm not sure where AdminReadonlyField would get it, anyway).

Attachments (6)

patch.diff (3.4 KB) - added by alexbmeng@… 6 years ago.
Added help_text to readonly admin fields
patch.2.diff (3.2 KB) - added by Yeago 6 years ago.
removed exception
patch.3.diff (3.2 KB) - added by Yeago 6 years ago.
removed exception
patch.4.diff (2.8 KB) - added by Yeago 6 years ago.
removed exception
patch.5.with_test.diff (4.1 KB) - added by wamberg 6 years ago.
git diff patch for help_text on readonly fields
14355_readonly_fields_help_text.diff (4.3 KB) - added by Julien Phalip 6 years ago.

Download all attachments as: .zip

Change History (15)

Changed 6 years ago by alexbmeng@…

Attachment: patch.diff added

Added help_text to readonly admin fields

comment:1 Changed 6 years ago by anonymous

Has patch: set

Changed 6 years ago by Yeago

Attachment: patch.2.diff added

removed exception

Changed 6 years ago by Yeago

Attachment: patch.3.diff added

removed exception

Changed 6 years ago by Yeago

Attachment: patch.4.diff added

removed exception

comment:2 Changed 6 years ago by Natalia Bidart

Owner: changed from nobody to Natalia Bidart

comment:3 Changed 6 years ago by Natalia Bidart

milestone: 1.3
Needs tests: set
Patch needs improvement: set
Triage Stage: UnreviewedAccepted

I confirmed that the help text is not being shown in the admin add/change form, for a read only field.

The patch attached by the reporter does not include tests for this fix, so I'm setting this bug properties accordingly.

comment:4 Changed 6 years ago by Natalia Bidart

Owner: changed from Natalia Bidart to nobody

comment:5 Changed 6 years ago by wamberg

Owner: changed from nobody to wamberg
Status: newassigned

Changed 6 years ago by wamberg

Attachment: patch.5.with_test.diff added

git diff patch for help_text on readonly fields

Changed 6 years ago by Julien Phalip

comment:6 Changed 6 years ago by Julien Phalip

Needs tests: unset
Patch needs improvement: unset
Triage Stage: AcceptedReady for checkin

Thank you alexbmeng, subsume and wamberg. Your latest patch looked good. I've just removed a line (self.help_text = ...) which was unnecessary and wrote some slightly more thorough tests. I believe this is RFC now.

comment:7 Changed 6 years ago by Russell Keith-Magee

Resolution: fixed
Status: assignedclosed

In [15582]:

Fixed #14355 -- Ensure that help_text is displayed for readonly fields in the admin. Thanks to jester for the report, and to alexbmeng, subsume, wamberg and Julien Phalip for ther work on the patch.

comment:8 Changed 6 years ago by Russell Keith-Magee

In [15583]:

[1.2.X] Fixed #14355 -- Ensure that help_text is displayed for readonly fields in the admin. Thanks to jester for the report, and to alexbmeng, subsume, wamberg and Julien Phalip for ther work on the patch.

Backport of r15582 from trunk.

comment:9 Changed 5 years ago by Jacob

milestone: 1.3

Milestone 1.3 deleted

Note: See TracTickets for help on using tickets.
Back to Top