Code

Opened 4 years ago

Closed 4 years ago

#14313 closed (invalid)

wrong display of field title in admin

Reported by: feuervogel Owned by: nobody
Component: contrib.admin Version: 1.2
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

I have a model with a field *timestamp_month* which I've added to the *list_display* field of the model's admin. In the template it's displayed as:

<a href="?timestamp_month__isnull=False&amp;timestamp_year__isnull=True&amp;o=4&amp;ot=asc">
Timestamp
</a></th><th>
<a href="?timestamp_month__isnull=False&amp;timestamp_year__isnull=True&amp;o=5&amp;ot=asc">
Month
</a></th>

Hence the HTML is generated deep down anywhere in the python code, I cannot provide a solution.

Attachments (0)

Change History (2)

comment:1 Changed 4 years ago by ramiro

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

Could you reduce your model and correspoding ModelAdmin to the minimal expression needed to reproduce the bug and paste it here please?.

comment:2 Changed 4 years ago by anonymous

  • Resolution set to invalid
  • Status changed from new to closed

sorry, cannot reproduce it.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.