Code

Opened 4 years ago

Closed 7 months ago

#14263 closed New feature (duplicate)

Allow fields to support custom double-underscore lookup methods

Reported by: carljm Owned by: nobody
Component: Database layer (models, ORM) Version: master
Severity: Normal Keywords:
Cc: jonas-django@…, ojiidotch@… Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

Rather than continually adding specialized builtin lookup types (e.g. #2616), there should be a good way for custom field types to support their own custom lookup types. Currently this is sort of possible, but requires monkeypatching the global singleton registry of lookup types, which is not ok.

Attachments (0)

Change History (7)

comment:1 Changed 4 years ago by carljm

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

Marking accepted per design discussion with core devs (Russell, Malcolm, Jannis) at sprint.

comment:2 Changed 3 years ago by julien

  • Severity set to Normal
  • Type set to New feature

comment:3 Changed 3 years ago by UloPe

  • Easy pickings unset
  • UI/UX unset

Related: #16187 Refactor of the lookup system

comment:4 Changed 3 years ago by jonash

  • Cc jonas-django@… added

comment:5 Changed 2 years ago by ojii

  • Cc ojiidotch@… added

comment:6 Changed 17 months ago by marcosmoyano

I believe this is related: https://code.djangoproject.com/ticket/6439

comment:7 Changed 7 months ago by apollo13

  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #16187

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.