Code

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#14245 closed (fixed)

django/contrib/flatpages/fixtures not included in the 1.2.2 release tarball

Reported by: pmclanahan Owned by: nobody
Component: Uncategorized Version: 1.2
Severity: Keywords:
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

This is potentially due to an oversight with the MANIFEST.in file. The fixtures directory and json file within were a recent addition. cramm on IRC suggested the following line be added to MANIFEST.in

recursive-include django/contrib/flatpages/fixtures *

Attachments (0)

Change History (5)

comment:1 follow-up: Changed 4 years ago by pmclanahan

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

Actually, I just did an experiment and found potentially more missing files in the tarball.

I took the following steps.

# Downloaded the 1.2.2 tarball from the homepage
# Extracted it into a new svn repo
# Added and checked in all of the files
# Checked out the releases/1.2.X branch from the django repo
# Exported everything from that checkout and coppied it over to my new repo, overwriting everything

After that the following output is observed:

$ svn status
?       django/dispatch/license.txt
?       django/contrib/admin/templates/widget
?       django/contrib/admin/templates/admin_doc
?       django/contrib/flatpages/fixtures
?       django/contrib/flatpages/tests/templates
?       tests/regressiontests/views/locale/en
?       docs/_build
?       docs/ref/contrib/_images

I'm not sure all of those are necessary, but that seems to be a decent diff of what's in the repo vs. what made it into the official tarball.

comment:2 in reply to: ↑ 1 Changed 4 years ago by pmclanahan

Replying to pmclanahan:

Doh! That should be:

  1. Downloaded the 1.2.2 tarball from the homepage
  2. Extracted it into a new svn repo
  3. Added and checked in all of the files
  4. Checked out the releases/1.2.X branch from the django repo
  5. Exported everything from that checkout and coppied it over to my new repo, overwriting everything

comment:3 Changed 4 years ago by anonymous

  • Triage Stage changed from Unreviewed to Accepted

comment:4 Changed 4 years ago by russellm

  • Resolution set to fixed
  • Status changed from new to closed

(In [13719]) Fixed #14245 -- Added some files and paths missing from the MANIFEST.in. Thanks to pmclanahan for the report.

comment:5 Changed 4 years ago by russellm

(In [13720]) [1.2.X] Fixed #14245 -- Added some files and paths missing from the MANIFEST.in. Thanks to pmclanahan for the report.

Backport of r13719 from trunk.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.