Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#14187 closed (fixed)

Add support for bpython in django-admin.py shell

Reported by: jdunck Owned by: nobody
Component: Core (Management commands) Version: 1.2
Severity: Keywords: sprintnov13
Cc: Triage Stage: Accepted
Has patch: yes Needs documentation: no
Needs tests: yes Patch needs improvement: no
Easy pickings: UI/UX:

Description

bpython is a lighter-weight curses-based rich shell for python.
http://bpython-interpreter.org/

It seems natural that django-admin.py shell should support this as well as IPython.

I didn't see test for the shell management command, so no tests are included here -- but docs have been updated to match. Please let me know if I've missed shell management tests.

Attachments (1)

bpython-14187.diff (3.4 KB) - added by jdunck 5 years ago.
First cut.

Download all attachments as: .zip

Change History (7)

Changed 5 years ago by jdunck

First cut.

comment:1 Changed 5 years ago by jdunck

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

This is debatably a dupe of #11542. I think this patch is simpler, but I may be biased. There's been no activity on that patch for a while; appears stuck at "design decision needed".

comment:2 Changed 5 years ago by jcscoobyrs

As someone interested in having Django use smarter shells when available, I went ahead and applied the patch locally to test it. It worked like a charm. I'm not sure if feedback like this is important or not but I like what I see.

comment:3 Changed 4 years ago by ericholscher

  • Needs tests set
  • Triage Stage changed from Unreviewed to Accepted

Looks good to me. AFAIK we don't test that ipython works. However, this seems like a nice place that mocking would be useful (define an 'ipython' on the pythonpath, and confirm that that part of the code is executed correctly).

Since it isn't already tested, I don't know if tests are really necessary for checkin, but I know that we try to get parts that aren't tested to have tests when they're touched.

comment:4 Changed 4 years ago by steph

  • Keywords sprintnov13 added

comment:5 Changed 4 years ago by jezdez

  • Resolution set to fixed
  • Status changed from new to closed

(In [14896]) Fixed #14187 -- Added support for bpython to shell management command. Thanks, Jeremy Dunck.

comment:6 Changed 4 years ago by jacob

  • milestone 1.3 deleted

Milestone 1.3 deleted

Note: See TracTickets for help on using tickets.
Back to Top