Opened 5 years ago

Closed 5 years ago

#14178 closed (duplicate)

Wrong dateformat in admin edit form

Reported by: danielaa Owned by: nobody
Component: Uncategorized Version: 1.2
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:


I am from Germany and using USE_L10N=True works fine all in all. But I found a little problem with the localisation of a datefield in the admin-interface. If I want to edit an already existing object the saved date ist formatted as "yyyy-mm-dd". If I click on "today" the correct german format ( is used again. It is not a show-stopper, because everything can be saved either way. I am using MySQL and in the database the value is saved as yyyy-mm-dd. So I think the admin-interface just reads the value from the database without formatting it according to the LANGUAGE_CODE-setting.

Change History (1)

comment:1 Changed 5 years ago by russellm

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #13679, which has been fixed in trunk, and will be in 1.2.2 when that release is made.

Note: See TracTickets for help on using tickets.
Back to Top