Opened 5 years ago

Closed 5 years ago

#14143 closed (invalid)

Database problems and import error of django.contrib.messages

Reported by: Robbington Owned by: nobody
Component: Uncategorized Version: 1.2
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description (last modified by kmtracey)

Hi, I am using django1.2 and django-cms on ubuntu 10

Have been using and teaching myself django for a few months now with minimal complaint, but I've just started a new project and things have been acting very strangly.

Basically I started a new project, configured everything and linked it to my database, sync-ed everything and got the admin working fine. Wrote a new blog app worked out the kinks by importing it in the shell until it all worked fine and added it to my installed apps and went to sync but get:

django.core.exceptions.ImproperlyConfigured?: You haven't set the DATABASE_ENGINE setting yet. 

Now I know what this means normally, but as I said I had previously synced the admin and got everything working, all that I had changed was adding the model to my installed apps.

Here is the exert from my


'default': { 

'ENGINE': 'sqlite3', 


About the same time shell throws up no module named messages. Checked and for some reason django.contrib.messages is no longer on the python path. Added it location to .pth file in the dist-packages, but still it cant find it. I had a similar problem importing module and had to re-install everything but it finds pages fine now.

Any ideas?

Change History (1)

comment:1 Changed 5 years ago by kmtracey

  • Description modified (diff)
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to invalid
  • Status changed from new to closed

Fixed formatting, please use WikiFormatting and preview before submitting. Also this problem is almost certainly a configuration problem on your machine, so would better be direction to the django-users mailing list or #django irc channel.

Both of the errors you mention would happen if your PYTHONPATH was pointing to a pre-1.2 Django: your 1.2 style database definitions would not be recognized and the new 1.2 messages module would not be found. So I suspect somehow your environment has been changed and you are no longer picking up the right version of Django for your project.

Note: See TracTickets for help on using tickets.
Back to Top