Code

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#14123 closed (fixed)

Trunk tests broken as of r13588 (1.2.x passes)

Reported by: PaulM Owned by: nobody
Component: Testing framework Version: master
Severity: Keywords:
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Tests on trunk are broken as of r13588. I'm not sure quite what the issue is, but the tests that patch introduced don't pass. The 1.2.x branch had the same patch applied and works fine.

In regressiontests.admin_views.tests.AdminDocsTest

AssertionError: Found 0 instances of '<h2>Built-in filters</h2>' in response (expected 2)

Attachments (1)

skip_tests.patch (1.0 KB) - added by lrekucki 4 years ago.
Simple test skips.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 4 years ago by PaulM

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to invalid
  • Status changed from new to closed

Looks like my error on this one.

Changed 4 years ago by lrekucki

Simple test skips.

comment:2 Changed 4 years ago by lrekucki

  • Resolution invalid deleted
  • Status changed from closed to reopened
  • Triage Stage changed from Unreviewed to Accepted

This tests fail due to lack of Docutils. Citing django docs: "Each of these dependencies is optional. If you're missing any of them, the associated tests will be skipped.". I think it should be fixed.

comment:3 Changed 4 years ago by russellm

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [13606]) Fixed #14123 -- Made AdminDocs tests optional, based on the availability of docutils. Thanks to PaulM for the original report, and Łukasz Rekucki for narrowing down the cause.

comment:4 Changed 4 years ago by russellm

(In [13607]) [1.2.X] Fixed #14123 -- Made AdminDocs tests optional, based on the availability of docutils. Thanks to PaulM for the original report, and Łukasz Rekucki for narrowing down the cause.

Backport of r13606 from trunk.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.