Opened 5 years ago

Closed 5 years ago

Last modified 3 years ago

#14044 closed (duplicate)

"required=False" dones't work when use DateTimeField with SplitDateTimeWidget

Reported by: codeplayer Owned by: yuval_a
Component: Forms Version: master
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

in django shell, this bug can be reproduced like this:

In [1]: from django.forms import *

In [2]: class TForm(Form):
   ...:     d = DateTimeField(widget=SplitDateTimeWidget, required=False)
   ...: 

In [3]: print TForm(data={'d':''}).errors
<ul class="errorlist"><li>d<ul class="errorlist"><li>Enter a valid date/time.</li></ul></li></ul>

Change History (3)

comment:1 Changed 5 years ago by yuval_a

  • milestone set to 1.3
  • Needs documentation unset
  • Needs tests unset
  • Owner changed from nobody to yuval_a
  • Patch needs improvement unset

comment:2 Changed 5 years ago by lrekucki

  • Resolution set to duplicate
  • Status changed from new to closed

Looks like a duplicate of #8898.

comment:3 Changed 3 years ago by jacob

  • milestone 1.3 deleted

Milestone 1.3 deleted

Note: See TracTickets for help on using tickets.
Back to Top