Code

Opened 4 years ago

Closed 4 years ago

#13932 closed (invalid)

URL with Hash and login_required

Reported by: azim@… Owned by: nobody
Component: contrib.auth Version: 1.2
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

If i try to open any login required site(decorator @login_required()) with hash on URL (like http://example.com/#profiles/user/edit), it will redirected to http://example.com/login/?next=/#profiles/user/edit

But after login, it redirected to http://example.com/ and not to http://example.com/#profiles/user/edit

Attachments (0)

Change History (3)

comment:1 follow-up: Changed 4 years ago by ivan@…

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

Sure, your link http://example.com/login/?next=/#profiles/user/edit is actually the link http://example.com/login/?next=/ with html id #profiles/user/edit.

So Django understand it as http://example.com/login/?next=/, it's normal and can't be fixed.

comment:2 in reply to: ↑ 1 Changed 4 years ago by anonymous

Sorry, my previous comment was wrong, because I can't reproduce the bug.

My actions:

  • Signed in

So please provide more details or test case.

comment:3 Changed 4 years ago by mtredinnick

  • Resolution set to invalid
  • Status changed from new to closed

Redirects at the HTTP level can't preserve anchors and that's how the login pass works. The server never sees the anchor and without Ajax-y tricks, there's nothing we can do. Closing for now, based on what's known here.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.