Opened 10 years ago

Closed 8 years ago

#139 closed enhancement (duplicate)

edit_inline should grow some Javascript magic to increase usability

Reported by: rmunn@… Owned by: tmervyn@…
Component: contrib.admin Version:
Severity: normal Keywords: edit_inline
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

The edit_inline functionality is very nice, but I want more:

  • When I start typing in the last "Choices" field, I want a new, blank Choice entry to automagically appear below it.
  • When a new Choice entry appears, I want it properly inserted into the tab order so that I can just hit Tab and move to the new entry.

In other words, it should be possible to create a new Poll, click on the first Choice tab, and start typing:

Strongly agree <tab> 0 <tab> Agree <tab> 0 <tab> No opinion <tab> 0 <tab> Disagree <tab> 0 <tab> Strongly disagree <tab> 0 <enter>

This would make adding an arbitrary number of choices much more streamlined. Currently I have to click the "Save and continue Editing" button after adding each choice, which means my hands have to leave the keyboard and travel over to the mouse.

Change History (10)

comment:1 Changed 10 years ago by rmunn@…

  • Severity changed from normal to enhancement

Oops, I meant this to be an enhancement request, not a bug report.

comment:2 Changed 10 years ago by adrian

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #13.

comment:3 Changed 8 years ago by anonymous

  • Resolution duplicate deleted
  • Status changed from closed to reopened

comment:4 Changed 8 years ago by anonymous

  • Owner changed from adrian to sharma_vivek@…
  • Status changed from reopened to new

comment:5 Changed 8 years ago by anonymous

  • Owner changed from sharma_vivek@… to sharma.vivek82@…

comment:6 Changed 8 years ago by anonymous

  • Owner changed from sharma.vivek82@… to kumarabhijit1@…

comment:7 Changed 8 years ago by anonymous

  • Owner changed from kumarabhijit1@… to nisha.gun@…

comment:8 follow-up: Changed 8 years ago by anonymous

  • Has patch set
  • Needs documentation set
  • Needs tests set
  • Owner changed from nisha.gun@… to tmervyn@…
  • Patch needs improvement set

comment:9 in reply to: ↑ 8 Changed 8 years ago by anonymous

Replying to anonymous:

comment:10 Changed 8 years ago by Paul Bx <pb@…>

  • Has patch unset
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Reverted spambot-like twiddling

Note: See TracTickets for help on using tickets.
Back to Top