Opened 5 years ago

Closed 5 years ago

#13858 closed (duplicate)

Overriding values of ModelForm seems not working.

Reported by: melug Owned by: nobody
Component: Forms Version: 1.2
Severity: Keywords: User creation, bug
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

I was trying to override the help text of UserCreationForm. I think i'm not doing something wrong. Here is my source code in forms.py:

class MyUserCreationForm(UserCreationForm):
    groups = models.ManyToManyField(Group, verbose_name = 'groups', help_text = 'No help')
    class Meta:                
        model = User           
        fields = ("username", "first_name", "last_name" , "groups", )

It render's form with help text:
In addition to the permissions manually assigned, this user will also get all permissions granted to each group he/she is in. Hold down "Control", or "Command" on a Mac, to select more than one.

Change History (1)

comment:1 Changed 5 years ago by kmtracey

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #12359 and #9321.

Note: See TracTickets for help on using tickets.
Back to Top