Code

Opened 4 years ago

Closed 4 years ago

Last modified 3 years ago

#13832 closed (duplicate)

Changeset #13363 broke PostgreSQL support for app names with uppercase characters

Reported by: DrMeers Owned by: DrMeers
Component: Database layer (models, ORM) Version: master
Severity: Keywords: postgresql, uppercase, table_name
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

As described here http://www.postgresql.org/docs/8.4/static/functions-info.html#FUNCTIONS-INFO-CATALOG-TABLE, for pg_get_serial_sequence(table_name, column_name), "Because the first parameter is potentially a schema and table, it is not treated as a double-quoted identifier, meaning it is lowercased by default, while the second parameter, being just a column name, is treated as double-quoted and has its case preserved"

Attachments (1)

13832.diff (3.5 KB) - added by DrMeers 4 years ago.

Download all attachments as: .zip

Change History (5)

Changed 4 years ago by DrMeers

comment:1 Changed 4 years ago by Alex

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

This looks like a dupe of #13821.

comment:2 Changed 4 years ago by DrMeers

Ah, yes it is; no keyword searches brought that one up for me thanks to the comparatively ambiguous title and description.

My patch is better than the one provided for #13821 mind you, as it uses quote_name and includes a regression test.

comment:3 Changed 4 years ago by Alex

I agree, feel free to reupload the patch ;)

comment:4 Changed 3 years ago by jacob

  • milestone 1.3 deleted

Milestone 1.3 deleted

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.