Opened 9 years ago

Closed 8 years ago

#1380 closed enhancement (wontfix)

Better title ordering on project website

Reported by: anonymous Owned by: jacob
Component: *.djangoproject.com Version:
Severity: trivial Keywords: page titles
Cc: Triage Stage: Design decision needed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

The website should have the actual page name at the begining of the title so you can tell what the tabs are for when you have lots of them open. This will increase usability.

Change History (6)

comment:1 Changed 9 years ago by Tom Tobin <korpios@…>

I strongly disagree with this; what happens when you have lots of tabs open, and only one of them is for the Django website? Or if you are bookmarking a page on the Django site, and your bookmarks thereby become sorted based on a subpage rather than the site name? If you were running "DjangoFox" as your browser, and only accessed Django sites, you might have a case. ;-) As it stands, insofar as this is a usability issue, the fault lies with the browser rather than the website.

comment:2 Changed 9 years ago by anonymous

On the admin it is done this way. Look

 _________________________________________________________________
|Django | T|Django | T|  Google  |Slashdot -|Change ent|TemplateSy|

Vs
 _________________________________________________________________
|#1380 (Bet|Documentat|  Google  |Slashdot -|Change ent|TemplateSy|

comment:3 Changed 9 years ago by Tom Tobin <korpios@…>

I feel the admin should output titles the other way, and I've altered my admin template to match for the reasons I've cited. :-p

comment:4 Changed 9 years ago by andy@…

Was going to submit this as a ticket, but found it was already here:

I strongly disagree with this; what happens when you have lots of tabs open, and only one of them is for the Django website?

That case is not an issue: most of the titles on other sites can be expected to start differently. The exception would be if you happened to be viewing lots of tickets on different trac sites (then they'd all look like #1380, only with diffent numbers). But I would doubt this is anywhere near as common as having multiple tabs open to different pages in the Django docs -- which is my particular use case. Even with only 7 tabs open, all I can see on them is "Django | Documentation ...", which is not much use.

Or if you are bookmarking a page on the Django site, and your bookmarks thereby become sorted based on a subpage rather than the site name?

If you're bookmarking a page, it's up to you either to name it to suit you or to organise it into a folder to suit you. Now you're blaming the site for user error ;-)

comment:5 Changed 9 years ago by Simon G. <dev@…>

  • Keywords page titles added
  • Triage Stage changed from Unreviewed to Design decision needed

comment:6 Changed 8 years ago by mtredinnick

  • Resolution set to wontfix
  • Status changed from new to closed

Duplicate of #2840 and closing as wontfix because of the discussion around that ticket. The problem is that there is no perfect, completely portable solution to this one.

Note: See TracTickets for help on using tickets.
Back to Top