Code

Opened 4 years ago

Closed 4 years ago

#13787 closed (duplicate)

AuthenticationForm renders incorrect passwords

Reported by: Ciantic Owned by: nobody
Component: contrib.auth Version: 1.2
Severity: Keywords: passwordinput AuthenticationForm
Cc: Ciantic Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

If user fails to log in using django.contrib.auth.forms.AuthenticationForm the user is given form where password is filled with incorrect last try.

Instead AuthenticationForm's field Password should use the PasswordInput widget's parameter render_value, which turned as False would hide the incorrect passwords.

Attachments (0)

Change History (2)

comment:1 Changed 4 years ago by russellm

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

Duplicate of #13316

comment:2 Changed 4 years ago by russellm

  • Resolution set to duplicate
  • Status changed from new to closed

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.