Opened 5 years ago

Closed 5 years ago

#13737 closed (duplicate)

Hide the extra column added by #11791

Reported by: acdha Owned by: nobody
Component: contrib.admin Version: 1.2
Severity: Keywords:
Cc: chris@… Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:


#11791 fixed HTML markup but it now results in an extra empty column being displayed on the change_list when using list_editable. This looks a little odd since there's no content and it doesn't have a corresponding table header. Example markup:

<tr class="row1">
    <td><input type="checkbox" class="action-select" value="114" name="_selected_action" /></td>
    <th><a href="114/">114</a></th><td>99</td><td>&nbsp;</td>
    <td><input type="checkbox" name="form-0-published" id="id_form-0-published" /></td>
    <td><input type="hidden" name="form-0-id" value="114" id="id_form-0-id" /></td>

There's a trivial jQuery hack - I'm not sure if it'd be preferable to set CSS instead but this works easily and it works on any browser:

django.jQuery("#result_list td:has(input[type=hidden]:only-child)").hide()

Change History (1)

comment:1 Changed 5 years ago by russellm

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #13599

Note: See TracTickets for help on using tickets.
Back to Top