Code

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#13698 closed (fixed)

whitespace at end of line in regressiontests/utils/timesince.py causes doctest to fail

Reported by: anonymous Owned by: nobody
Component: Testing framework Version: 1.2
Severity: Keywords: timesince doctest
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Lines 93, 95, 97 have redundant whitespace at the end of the line

Attachments (0)

Change History (3)

comment:1 Changed 4 years ago by kmtracey

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

I can't recreate any failures for this doctest on Linux or Windows. Under what environment do you see doctests failing due to trailing whitespace?

comment:2 Changed 4 years ago by russellm

  • Resolution set to fixed
  • Status changed from new to closed

(In [13323]) Fixed #13698 -- Removed trailing whitespace from regressiontests/utils/timesince. Officially, I'm doing this because trailing whitespace is bad, but apparently it also causes test failures for some people (for reasons we can't narrow down), so there's a double win.

comment:3 Changed 4 years ago by russellm

For the record - this was previously reported as #10988.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.