Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#13690 closed (invalid)

django admin use 102 SQL querys when i set the permission of a user!

Reported by: lsc20051426@… Owned by: nobody
Component: contrib.admin Version: 1.2
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:


django admin use 102 SQL querys when I set the permissions for a user!
see the picture !

Attachments (1)

admin 102 querys.JPG (72.7 KB) - added by lsc20051426 5 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 5 years ago by d0ugal

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

I think you intended to add file to this ticket - but there isn't one. Also, can you provide the code or more explication about this problem.

At present we have very little to go on and depending what your doing it may be the expected behaviour.

Changed 5 years ago by lsc20051426

comment:2 Changed 5 years ago by lsc20051426

ok,I have submit it .
BTW ,i register an user for attaching a jpg.

comment:3 Changed 5 years ago by russellm

  • Resolution set to invalid
  • Status changed from new to closed

Closing invalid due to a the absence of a specific course of action. 102 queries is certainly a lot, but unless you can point at a specific performance problem that this is causing, or a specific optimization that can be achieved, it doesn't really help having an open ticket that claims "admin could be better". Everything can always be better.

Feel free to reopen if you can identify a specific improvement that can be made.

comment:4 Changed 5 years ago by kmtracey

#14090 reported this again and did propose a fix.

Note: See TracTickets for help on using tickets.
Back to Top