Opened 5 years ago

Closed 5 years ago

#13673 closed (worksforme)

DEBUG=False and 404 / Flatpages

Reported by: michael.miller@… Owned by: nobody
Component: Uncategorized Version: 1.2
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: yes
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:


Flatpages and 404 Errors work as expected when running in DEBUG=True mode.

Setting DEBUG=False disables flatpages and 404 errors return the correct 404 page but with 200 Http Code and not 404 code.

Change History (3)

comment:1 Changed 5 years ago by Michael Miller

  • Needs documentation set
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to fixed
  • Status changed from new to closed

one should mention in the docs that when defining own handler404/handler500 in the that these views do return with HttpResponseNotFound or HttpResponseServerError

comment:2 Changed 5 years ago by anonymous

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:3 Changed 5 years ago by russellm

  • Resolution set to worksforme
  • Status changed from reopened to closed

I can't reproduce this. flatpages works fine for me, regardless of the value of DEBUG.

Note: See TracTickets for help on using tickets.
Back to Top