Code

Opened 4 years ago

Closed 3 years ago

Last modified 3 years ago

#13577 closed (fixed)

New Polish L10N formats file

Reported by: ludwik Owned by: lrekucki
Component: Translations Version: 1.2
Severity: Keywords:
Cc: Triage Stage: Accepted
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: yes
Easy pickings: UI/UX:

Description

Updated Polish formats.py file, taking advantage of new L10N features in Djnago 1.2.

Attachments (2)

polish_formats.diff (1.4 KB) - added by ludwik 4 years ago.
polish_formats.2.diff (1.4 KB) - added by konryd 3 years ago.
nbsp as thousand separator for polish locale

Download all attachments as: .zip

Change History (19)

Changed 4 years ago by ludwik

comment:1 Changed 4 years ago by russellm

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

comment:2 Changed 4 years ago by russellm

  • Triage Stage changed from Accepted to Ready for checkin

comment:3 Changed 4 years ago by jezdez

  • Resolution set to fixed
  • Status changed from new to closed

(In [13298]) Fixed #13577 -- Updated Polish formats file. Thanks, ludwik.

comment:4 Changed 4 years ago by sero

  • Resolution fixed deleted
  • Status changed from closed to reopened

Thousand separator should be ' ' (space) instead of '.' (dot). The old one was good.

comment:5 Changed 4 years ago by zgoda

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [13327]) Fixed #13577 - wrong thousands separator in Polish formats file. Thanks sero for report.

comment:6 follow-up: Changed 4 years ago by ludwik

Replying to sero:
I believe both formats are valid. I have nothing against changing it to space, but it would have to be a non-breaking space (there is nothing worst then a line break in the middle of a number). My first instinct would be to just put " " there, but I don't think it would be a good solution. The problem is those formats can probably be used outside of HTML space, so using an HTML entity could break things...

comment:7 in reply to: ↑ 6 Changed 4 years ago by lrekucki

  • Resolution fixed deleted
  • Status changed from closed to reopened

Replying to ludwik:

I believe both formats are valid.

Don't know about the dot, by the typesetting standard (PN-83) says it it should be a 2pt. width space.

I have nothing against changing it to space, but it would have to be a non-breaking space (there is nothing worst then a line break in the middle of a number). My first instinct would be to just put " " there, but I don't think it would be a good solution. The problem is those formats can probably be used outside of HTML space, so using an HTML entity could break things...

Check out unicode character "\u2009" ( ). It has the right width and it's recomended as a thousands separator. AFAIR, Django templates are always unicode, so it could do the trick. I agree with you that an ordinary space is a bit confusing and will cause problems with line breaks, so I think I'll open this again.

comment:8 Changed 4 years ago by russellm

  • Triage Stage changed from Ready for checkin to Accepted

comment:9 Changed 3 years ago by claudep

  • Has patch unset

Needs a new patch

comment:10 Changed 3 years ago by zgoda

  • Owner zgoda deleted
  • Status changed from reopened to new

comment:11 Changed 3 years ago by lrekucki

  • milestone set to 1.3
  • Owner set to lrekucki

comment:12 Changed 3 years ago by russellm

  • Has patch set
  • Patch needs improvement set

FYI - The only thing holding this back from 1.3 is a consensus on the right solution. The patch is still using a dot; discussion seems to suggest that Polish standards indicate a nonbreakable space is appropriate.

If someone can resolve this discussion (and update the patch if required), please mark RFC and I'll commit.

comment:13 Changed 3 years ago by claudep

Just checked in CLDR data set, Polish has non-breaking space as thousand separator.

comment:14 Changed 3 years ago by konryd

For thinsp / against nbsp:

  • It honors the standard PN-83 which is polish typesetting standard (which I currently don't have access to, and my Google-fu is failing)

For nbsp / against thinsp:

  • the unbreaking behaviour is desirable
  • thinsp seems esoteric to me (please correct me if I'm wrong)
  • this page says Opera doesn't display thinsp properly: http://en.wikipedia.org/wiki/Template:Thinsp
  • CLDR data set confirms this option

I'd say use nbsp. I'm happy with submitting a patch, but I'm not sure if putting unicode there wouldn't break things.

Changed 3 years ago by konryd

nbsp as thousand separator for polish locale

comment:15 Changed 3 years ago by jezdez

In [15843]:

Refined changes to Polish localization format file made in r13298 and r13327 by using non-breaking space. Refs #13577.

comment:16 Changed 3 years ago by jezdez

  • Resolution set to fixed
  • Status changed from new to closed

Uh, closing, this shouldn't have been reopened in the first place because there was a commit already.

comment:17 Changed 3 years ago by jacob

  • milestone 1.3 deleted

Milestone 1.3 deleted

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.