Code

Opened 4 years ago

Closed 4 years ago

Last modified 3 years ago

#13554 closed (duplicate)

shell: IPython 0.11 API change, use IPythonApp if detected, fallback for <=0.10

Reported by: jfkw Owned by: nobody
Component: Testing framework Version: 1.1
Severity: Keywords: ipython shell
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

django-admin.py shell uses IPython if detected. The IPython git master branch (IPython 0.11) has a breaking change affecting Django.

Old way:

shell = IPython.Shell.IPShell(argv=[])
shell.mainloop()

New way:

app = IPythonApp(argv=[])
app.start()

IPython-0.10 is the latest release on PyPI, IPython-0.11 is only in alpha.

Attachments (1)

ipython-0_10_and_0_11_support.patch (1.2 KB) - added by jfkw 4 years ago.
Patch to try IPython 0.11 API, fall back to 0.10 API otherwise.

Download all attachments as: .zip

Change History (3)

Changed 4 years ago by jfkw

Patch to try IPython 0.11 API, fall back to 0.10 API otherwise.

comment:1 Changed 4 years ago by ramiro

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #12735.

comment:2 Changed 3 years ago by jacob

  • milestone 1.2 deleted

Milestone 1.2 deleted

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.