Code

Opened 4 years ago

Closed 16 months ago

#13465 closed Cleanup/optimization (duplicate)

non_field_errors should be mentioned in the form api docs

Reported by: SmileyChris Owned by: nobody
Component: Documentation Version: master
Severity: Normal Keywords:
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: yes
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description


Attachments (0)

Change History (7)

comment:1 Changed 4 years ago by russellm

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to worksforme
  • Status changed from new to closed
  • Triage Stage changed from Unreviewed to Accepted

non_field_errors is mentioned in the form docs. If you think there is a need for something else, you'll need to be a little more specific.

comment:2 Changed 4 years ago by SmileyChris

  • Resolution worksforme deleted
  • Status changed from closed to reopened
  • Triage Stage changed from Accepted to Design decision needed

Sorry, I should have been more specific: I was thinking perhaps a crossreferencing sentence at the end of http://docs.djangoproject.com/en/1.1/ref/forms/api/#more-granular-output

This came from an IRC discussion and I had to hunt for the reference to non_field_errors.

I'll reopen for a decision to be made on whether that'd just be noise or a useful reference

comment:3 Changed 4 years ago by SmileyChris

  • Needs documentation set
  • Triage Stage changed from Design decision needed to Accepted

This came up again in IRC.

Reviewing the current docs again, the usage methods are inferred here, but never explicitly shown how they could be used (common usage as opposed to the current mention in custom validation docs).

comment:4 Changed 3 years ago by julien

  • Severity set to Normal
  • Type set to Cleanup/optimization

comment:5 Changed 2 years ago by aaugustin

  • UI/UX unset

Change UI/UX from NULL to False.

comment:6 Changed 2 years ago by aaugustin

  • Easy pickings unset

Change Easy pickings from NULL to False.

comment:7 Changed 16 months ago by bmispelon

  • Resolution set to duplicate
  • Status changed from reopened to closed

This looks like a duplicate of #14023 which was closed in 0f9eb912ffa015574ebb2d1fd6a2a78664a19039.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.