Code

Opened 4 years ago

Closed 4 years ago

#13403 closed (invalid)

trans escaped characters

Reported by: dandu Owned by: nobody
Component: Template system Version: master
Severity: Keywords: trans escape
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

with the latest svn version trans unescapes characters

code: {% trans "test\'test" %}

with beta 1.2 beta-1 this would render "test\'test", but with the latest svn version it renders "test'test"

Attachments (0)

Change History (1)

comment:1 Changed 4 years ago by russellm

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to invalid
  • Status changed from new to closed

"test'test" was the behaviour in 1.1, and it is the current behaviour of trunk, so there isn't any regression here. I also can't reproduce the problem in 1.2-beta 1.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.