Opened 5 years ago

Closed 5 years ago

#13380 closed (worksforme)

get_FOO_display fails in template on 1.2b1

Reported by: Digitalxero Owned by: nobody
Component: Template system Version: 1.2-beta
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

a model field (test) that has choices creates a get_test_display methods, this method works fine in the shell, but when I attempt to render it in a template {{model.get_test_display}} it fails on 1.2b1 and works on 1.1.x

Change History (1)

comment:1 Changed 5 years ago by russellm

  • milestone 1.2 deleted
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to worksforme
  • Status changed from new to closed

I can't reproduce this. I don't doubt you're seeing a problem, but we're going to need more details, like a specific failing test case. It isn't as simple as "{{ model.get_test_display }}" in a template.

Note: See TracTickets for help on using tickets.
Back to Top