Opened 12 years ago

Closed 12 years ago

Last modified 10 years ago

#13357 closed (fixed)

Various small fixes for Django+PyPy

Reported by: Alex Gaynor Owned by: nobody
Component: Uncategorized Version: dev
Severity: Keywords:
Cc: Triage Stage: Accepted
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

They're all dict ordering, except for one that relies on the fact that CPython allows kwargs on dict(), but not other functions (no idea why), PyPy prohibits them on both, which is the safer behavior.

Attachments (2)

django-pypy.diff (5.9 KB) - added by Alex Gaynor 12 years ago.
django-pypy.2.diff (8.1 KB) - added by Alex Gaynor 12 years ago.
This patch does all of the above, and fixes the cache tests (caused by files not being written because they aren't flushed because they aren't closed)

Download all attachments as: .zip

Change History (6)

Changed 12 years ago by Alex Gaynor

Attachment: django-pypy.diff added

comment:1 Changed 12 years ago by Russell Keith-Magee

Triage Stage: UnreviewedAccepted

Changed 12 years ago by Alex Gaynor

Attachment: django-pypy.2.diff added

This patch does all of the above, and fixes the cache tests (caused by files not being written because they aren't flushed because they aren't closed)

comment:2 Changed 12 years ago by Russell Keith-Magee

Resolution: fixed
Status: newclosed

(In [12991]) Fixed #13357 -- Minor changes to get Django running under PyPy. Thanks to Alex Gaynor for the patch.

comment:3 Changed 12 years ago by Russell Keith-Magee

(In [12992]) [1.1.X] Fixed #13357 -- Minor changes to get Django running under PyPy. Thanks to Alex Gaynor for the patch.

Backport of r12991 from trunk.

comment:4 Changed 10 years ago by Jacob

milestone: 1.2

Milestone 1.2 deleted

Note: See TracTickets for help on using tickets.
Back to Top