Code

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#13325 closed (duplicate)

admin RelatedFieldWidgetWrapper bugfix

Reported by: anthony@… Owned by: nobody
Component: contrib.admin Version: master
Severity: Keywords: admin, RelatedFieldWidgetWrapper
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

a simple patch that checks if the user has permission to add for a model before displaying the little green cross next to selectboxes in admin. I havent found this subject in ticket tracker and seems simple, so i submit a patch.

Attachments (1)

check_perms_related_widget.diff (2.2 KB) - added by anthony@… 4 years ago.

Download all attachments as: .zip

Change History (3)

Changed 4 years ago by anthony@…

comment:1 Changed 4 years ago by ramiro

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #1035 that has a patch that contains tests and is already marked as ready for checkin.

comment:2 Changed 4 years ago by anthony@…

oh, i hadnt seen that one, sry

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.