Code

Opened 4 years ago

Closed 4 years ago

#13302 closed (duplicate)

fatal lock up on compile of template with {% url ... %}

Reported by: crucialfelix@… Owned by: nobody
Component: Template system Version: 1.2-beta
Severity: Keywords:
Cc: crucialfelix@… Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

# this url pattern is valid:
from django.core.urlresolvers import reverse
print reverse('add_to_collection',kwargs={'model':'someklass','collection_id':1})
# '/collections/add_to/someklass/1'

# url(r'^add_to/(?P<model>[0-9A-Za-z]+)/(?P<collection_id>\d+)$',
#     view = 'collectionz.views.add_to_collection',
#     name = "add_to_collection"
# ),

# given a template that can be reduced to just that url:
# {% url add_to_collection model=collection.model_class,collection_id=collection.id %}

# merely loading/compiling this template causes the process to lock up with 99% CPU, must be KILLed
path = "collectionz/manage_collection_search_results.html"


from django.template import loader

loader.get_template(path)

django-trunk@12937

using 12811 it behaves normally

when I get a chance I will bisect and find the specific change and look into it more.

Attachments (0)

Change History (1)

comment:1 Changed 4 years ago by Alex

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #13275.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.