Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#13239 closed (fixed)

'makemessages' regression test raises error on close

Reported by: russellm Owned by: nobody
Component: Testing framework Version: 1.2-beta
Severity: Keywords:
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:


If you run the makemessages unit test, you get an error printed after the test success has been reported::

Exception exceptions.AttributeError: "'NoneType' object has no attribute 'maxint'" in <bound method Popen.__del__ of <subprocess.Popen object at 0x128bef0>> ignored

This appears to be due to a bug in Python, but there's an easy workaround - manually force the deletion of the Popen object.

Change History (3)

comment:1 Changed 6 years ago by russellm

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted
  • Version changed from 1.1 to 1.2-beta

comment:2 Changed 6 years ago by russellm

  • Resolution set to fixed
  • Status changed from new to closed

(In [12874]) Fixed #13239 -- Forced the deletion of the Popen object, avoiding a bug in Python's subprocess cleanup code.

comment:3 Changed 4 years ago by jacob

  • milestone 1.2 deleted

Milestone 1.2 deleted

Note: See TracTickets for help on using tickets.
Back to Top