Code

Opened 4 years ago

Closed 4 years ago

Last modified 3 years ago

#13229 closed (fixed)

List of Finnish municipalities updated for the year 2010 (fi_municipalities.py)

Reported by: Haprog Owned by: nobody
Component: contrib.localflavor Version: master
Severity: Keywords: fi,finnish,municipalities
Cc: Triage Stage: Accepted
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

I updated the list of Finnish municipalities in django\contrib\localflavor\fi\fi_municipalities.py to correspond to current municipalities in 2010.

Attachments (1)

localflavor_fi_municipalities_2010.diff (11.9 KB) - added by Haprog 4 years ago.

Download all attachments as: .zip

Change History (6)

Changed 4 years ago by Haprog

comment:1 Changed 4 years ago by russellm

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

comment:2 Changed 4 years ago by russellm

  • Resolution set to fixed
  • Status changed from new to closed

(In [12958]) Fixed #13229 -- Updated the list of Finnish municipalities in localflavor. Thanks to Haprog for the patch.

comment:3 Changed 4 years ago by kmtracey

  • Resolution fixed deleted
  • Status changed from closed to reopened

There's apparently a test that relies on the data in this list of Finnish municipalities, since r12958 has triggered a test failure:

FAIL: Doctest: regressiontests.forms.tests.__test__.localflavor_fi_tests
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/buildbot/slave-py2.4/parts/ubuntu9.10-py2.4-sqlite/django-trunk_ubuntu9.10-py2.4-sqlite/build/django/test/_doctest.py", line 2180, in runTest
    raise self.failureException(self.format_failure(new.getvalue()))
AssertionError: Failed doctest test for regressiontests.forms.tests.__test__.localflavor_fi_tests
  File "/home/buildbot/slave-py2.4/parts/ubuntu9.10-py2.4-sqlite/django-trunk_ubuntu9.10-py2.4-sqlite/build/tests/regressiontests/forms/tests.py", line unknown line number, in localflavor_fi_tests

----------------------------------------------------------------------
File "/home/buildbot/slave-py2.4/parts/ubuntu9.10-py2.4-sqlite/django-trunk_ubuntu9.10-py2.4-sqlite/build/tests/regressiontests/forms/tests.py", line ?, in regressiontests.forms.tests.__test__.localflavor_fi_tests
Failed example:
    unicode(w.render('municipalities', 'turku'))
Expected:
    u'<select name="municipalities">\n<option value="akaa">Akaa</option>\n<option value="alaharma">Alah\xe4rm\xe4</option> [truncated due to length, you get the idea]
Got:
    u'<select name="municipalities">\n<option value="akaa">Akaa</option>\n<option value="alajarvi">Alaj\xe4rvi</option> [truncated due to length]


----------------------------------------------------------------------
Ran 1570 tests in 501.680s

FAILED (failures=1)

I'm a little puzzled by the fact that this updated list deletes a bunch of items. Doesn't that have backwards-incompatibility implications for anyone who has been using the old list and may have data from now-deleted items saved in their DB?

comment:4 Changed 4 years ago by russellm

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [12962]) Fixed #13229 -- Corrected a test failure caused by the change in Finnish municipalities from r12958. Thanks to Karen for the report.

comment:5 Changed 3 years ago by jacob

  • milestone 1.2 deleted

Milestone 1.2 deleted

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.