Code

Opened 4 years ago

Closed 4 years ago

#13148 closed (duplicate)

DEBUG_SHOW_DJANGO_TRACEBACK

Reported by: haras Owned by: nobody
Component: Contrib apps Version: master
Severity: Keywords: debug
Cc: djangoproject.com@… Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Hi,
Recently I was doing a lot of django works and every time I get a django DEBUG screen, there were a lot of unnecessary info, which complicated me a debugging process
in settings there should be an option DEBUG_SHOW_DJANGO_TRACEBACK which depends on value (True, False) shows django correlated traceback

it would be a lot easier than showing a 70 lines of
/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/site-packages/django/template/debug.py in render_node

than hiding (display hidden) it and displaying only this from my project
/web/myapp/myapp/models.py

and by default display block few lines of code in order to trace error

meta and settings should be displayed hidden (when you need them, then you unhide it)

and this is general problem
error messages are very inaccurate, so much, that sometimes it is hard to find where problem is

maybe adding some debugging output functions
for example when you want to test what is inside a dictionary
d = dict()
d{"asdas": asdasd, "a": "dd"}
debug(d)

and it would display at the debug page its content, and of course types like:
d { - dict
"asdas": object (asdasd),
"a": str("dd")
}
or similar

I love django and made a lot of projects using it, keep it going folks! I love this framework.

Attachments (0)

Change History (1)

comment:1 Changed 4 years ago by russellm

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

I'm going to close this as a duplicate of #11834 - We don't need an additional setting, we need to improve the visual layout of the debug page. This can mean making internal Django stack frames easier to identify (and therefore ignore), and visually collapsing Django stack frames by default (so you can still get to them, but

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.