Opened 9 years ago

Closed 9 years ago

#1310 closed defect (invalid)

make-messages.py created .po files contain 'invalid' flags

Reported by: j.rademaker@… Owned by: hugo
Component: Internationalization Version: master
Severity: normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

The .po files created make-messages.py by contain flags which prevent i18n from working properly.

Example:

#: models/test.py:18
#, fuzzy
msgid "test"
msgstr "somethingelse"

In this case _('test') wouldn't get translated. Removing '#, fuzzy' fixes the problem.

$ uname -a
FreeBSD dev2.BWSSBV.local 5.3-RELEASE FreeBSD 5.3-RELEASE #0: Fri Nov  5 04:19:18 UTC 2004     root@harlow.cse.buffalo.edu:/usr/obj/usr/src/sys/GENERIC  i386

$ xgettext --version
xgettext (GNU gettext-tools) 0.14.5
Copyright (C) 1995-1998, 2000-2005 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
Written by Ulrich Drepper.

$ python -V
Python 2.4.2

Change History (2)

comment:1 Changed 9 years ago by anonymous

  • Version set to SVN

comment:2 Changed 9 years ago by hugo

  • Resolution set to invalid
  • Status changed from new to closed

Nope, that will work as expected - it will translate correctly. But fuzzy shouldn't stay in the .po files - translators should change that and replace the fuzzy translation by the exact translation. This is standard gettext behaviour and stuff, not a bug.

Note: See TracTickets for help on using tickets.
Back to Top