Code

Opened 4 years ago

Closed 4 years ago

#13066 closed (duplicate)

cache.get and cache.set should have consistent key rules across different backends

Reported by: rbanffy Owned by: nobody
Component: Core (Cache system) Version: master
Severity: Keywords:
Cc: Triage Stage: Design decision needed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

As it is now, cache.get and cache.set accept keys with spaces when CACHE_BACKEND is set to 'locmem://', but memcached complains of keys with spaces. This makes tests work on a non-memcached setup (i.e. development workstation) and fail on the server (using memcached)

Attachments (0)

Change History (4)

comment:1 Changed 4 years ago by carljm

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted
  • Version changed from 1.2-beta to SVN

I've also been bitten by this.

comment:2 Changed 4 years ago by ubernostrum

  • milestone 1.2 deleted
  • Triage Stage changed from Accepted to Design decision needed

This isn't anywhere near important enough to be on the 1.2 milestone, and given the history of proposals related to this (see #6447 and #3241 in particular), probably needs a decision from the committers before being accepted.

comment:3 Changed 4 years ago by carljm

Fair enough re 1.2 milestone.

This is actually probably a duplicate of #6447, though this ticket more clearly requests what I think is the right solution; that the caching system should enforce the most-stringent key rules of any cache backend so code with bad keys fails fast rather than in production only. Seems like this is the unavoidable solution if cache backends are really intended to be interchangeable, and for caching to be usable by reusable code. AFAICS that solution was never proposed or rejected in any of the previous related tickets.

comment:4 Changed 4 years ago by carljm

  • Resolution set to duplicate
  • Status changed from new to closed

Marking duplicate of #6447.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.