Opened 11 years ago

Closed 11 years ago

Last modified 10 years ago

#1301 closed defect (fixed)

[magic-removal] AttributeError in DateQuerySet

Reported by: Esaj Owned by: Adrian Holovaty
Component: Metasystem Version: magic-removal
Severity: normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

AttributeError: 'DateQuerySet' object has no attribute '_field'

django/db/models/query.py in iterator, line 419

Looks like the problem is in django/db/models/query.py:104, because _field isn't copied during the call to _clone().

Attachments (1)

query.py.diff (669 bytes) - added by Esaj 11 years ago.
Fixes the bug

Download all attachments as: .zip

Change History (3)

Changed 11 years ago by Esaj

Attachment: query.py.diff added

Fixes the bug

comment:1 Changed 11 years ago by Esaj

The attached patch fixes this bug.

comment:2 Changed 11 years ago by Adrian Holovaty

Resolution: fixed
Status: newclosed

(In [2223]) magic-removal: Fixed #1301 -- Fixed AttributeError when QuerySet.dates() is filtered. Thanks, Esaj

Note: See TracTickets for help on using tickets.
Back to Top