Code

Opened 4 years ago

Closed 4 years ago

#12947 closed (worksforme)

Problem with django development server

Reported by: PawelRoman Owned by: nobody
Component: django-admin.py runserver Version: 1.1
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description (last modified by russellm)

I've noticed that django development server drops connection when submitting a long value in hidden field (didn't check for other input fields).

For example, clicking submit button in the form below (using internet explorer 6) will cause connection to drop and the browser will display standard error message "Cannot find server blah blah" (as if someone pulled the network cable). To get the same effect in firefox 3.5 you only need to extend this string a few times.

I can replicate it 100% on IE6 and Firefox 3.5.8 and if I had other browsers I suspect it would be the same. I know that this dev http server is a low priority stuff for django developers but it would be very nice to make it work correctly. I currently deal with large value in hidden field that must be submitted to the server and I cannot work wth the dev server on that :(

Later I've noticed, I was getting this kind of errors:

Exception happened during processing of request from ('127.0.0.1', 4101)
 File "C:\Python25\lib\SocketServer.py", line 241, in process_request
   self.finish_request(request, client_address)
 File "C:\Python25\lib\SocketServer.py", line 254, in finish_request
   self.RequestHandlerClass(request, client_address, self)
 File "C:\Python25\lib\site-packages\django\core\servers\basehttp.py", line 560, in __init__
   BaseHTTPRequestHandler.__init__(self, *args, **kwargs)
 File "C:\Python25\lib\SocketServer.py", line 522, in __init__
   self.handle()
 File "C:\Python25\lib\site-packages\django\core\servers\basehttp.py", line 600, in handle
   self.raw_requestline = self.rfile.readline()
 File "C:\Python25\lib\socket.py", line 381, in readline
   data = self._sock.recv(self._rbufsize)
error: (10054, 'Connection reset by peer')

This is the sample form that fails to get reply from the dev server (in IE6, after extending the string few times it also breaks under FF):

<div>
	<form id="myform" method="post" action=".">
		<div>
			<input type="hidden" value="test value which is a very long string test value which is a very long string test value which is a very long string test value which is a very long string test value which is a very long string test value which is a very long string test value which is a very long string test value which is a very long string test value which is a very long string test value which is a very long string test value which is a very long string test value which is a very long string test value which is a very long string test value which is a very long string " name="hiddenstuff" />
			<input type="submit" value="Submit!" />
		</div>
	</form>
</div>

Attachments (0)

Change History (1)

comment:1 Changed 4 years ago by russellm

  • Description modified (diff)
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to worksforme
  • Status changed from new to closed

I can't reproduce this problem.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.