Code

Opened 4 years ago

Closed 4 years ago

#12939 closed (duplicate)

fix for ExceptionReporter.get_traceback_html()

Reported by: skoom Owned by: nobody
Component: Template system Version: master
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

ExceptionReporter.get_traceback_html() checks if the exception has a 'source' attribute before running get_template_exception_info().

It should check the type of exception is TemplateSyntaxError as it says it does in the documentation.

It only checks if the exception has a 'source' attribute. I use mako templates and their compiler exception has a source value (which is a string) and the ExceptionReporter fails pulling this value into 3 values as it tries to on line 137 of views/debug.py.

Some of my template issues just show up as an error in debug.py at line 137.

Attachments (0)

Change History (4)

comment:1 Changed 4 years ago by skoom

  • Component changed from Uncategorized to Template system
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Version changed from 1.1 to SVN

comment:2 Changed 4 years ago by skoom

  • milestone set to 1.2

comment:3 Changed 4 years ago by skoom

  • milestone 1.2 deleted

comment:4 Changed 4 years ago by russellm

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #10216

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.